[Confirmed]Ship building bug -ships stuck on '0' cycles left

Space bugs, we hate em. Let us know where you saw that dirty Acean!

[Confirmed]Ship building bug -ships stuck on '0' cycles left

Postby Silligoose » Sat Feb 07, 2015 4:59 am

Priority: Medium
--Medium: Feature not working as intended

Reproduce: Yes

Description:
I've encountered a bug where my ships in the shipyard are stuck on '0' cycles during the building process. The warehouse isn't full, but there is enough res and funds to build ships queued. At times, I've had some ships be stuck on 0 for quite some time, while others ships complete on the same planet, at the same time.


Steps to reproduce:
Queue up ships on a planet that has all the funds/space/res needed

(edited to conform to template)
Last edited by Silligoose on Mon Feb 09, 2015 2:22 pm, edited 1 time in total.
Silligoose
 
Posts: 79
Joined: Wed Jan 29, 2014 7:18 am

Re: Ship building bug - ships stuck on '0' cycles left.

Postby Sypheria » Sat Feb 07, 2015 5:11 am

How many ships and how many components on all of them total?
Sypheria
User avatar
Universe Architect
 
Posts: 4225
Joined: Sun Aug 21, 2011 4:23 pm
Location: WinSock.h ln 458 #define AF_UNKNOWN1 20 /*Somebodys using this! */

Re: Ship building bug - ships stuck on '0' cycles left.

Postby Silligoose » Sat Feb 07, 2015 5:31 am

Right now I have a planet where there are 4 ships stuck on 0. Components per ship = 14.

Edit: Another planet had 5 ships queued up, 3 of which finished, 2 of which are stuck on 0. 14 components per ship once more.
Silligoose
 
Posts: 79
Joined: Wed Jan 29, 2014 7:18 am

Re: Ship building bug - ships stuck on '0' cycles left.

Postby Sypheria » Sat Feb 07, 2015 5:38 am

How many slots free in the warehouse?
Sypheria
User avatar
Universe Architect
 
Posts: 4225
Joined: Sun Aug 21, 2011 4:23 pm
Location: WinSock.h ln 458 #define AF_UNKNOWN1 20 /*Somebodys using this! */

Re: Ship building bug - ships stuck on '0' cycles left.

Postby Silligoose » Sat Feb 07, 2015 5:40 am

546/1200 storage space used, so 654 storage space open. Also a lot of free CP, so the problem doesn't lie there either. This is on Jovian 1463.

The second planet where 2 ships are stuck is Rocky 1469. I decided to queue up another 3 ships. 3 Ships finished, 2 still stuck on 0 cycle. Interestingly, before I queued up 3 additional ships, slows 4 and 5 were the ones stuck in shipyard. Now it is slots 3 and 5, with slot 4 having finished.
Silligoose
 
Posts: 79
Joined: Wed Jan 29, 2014 7:18 am

Re: Ship building bug - ships stuck on '0' cycles left.

Postby Sypheria » Sat Feb 07, 2015 5:50 am

Relog and recheck how many warehouse slots.
Sypheria
User avatar
Universe Architect
 
Posts: 4225
Joined: Sun Aug 21, 2011 4:23 pm
Location: WinSock.h ln 458 #define AF_UNKNOWN1 20 /*Somebodys using this! */

Re: Ship building bug - ships stuck on '0' cycles left.

Postby Silligoose » Sat Feb 07, 2015 5:53 am

Relogged. Warehouse slots used 568/1200
Silligoose
 
Posts: 79
Joined: Wed Jan 29, 2014 7:18 am

Re: Ship building bug - ships stuck on '0' cycles left.

Postby Sypheria » Sat Feb 07, 2015 5:55 am

Manually move things out of your factory.
Sypheria
User avatar
Universe Architect
 
Posts: 4225
Joined: Sun Aug 21, 2011 4:23 pm
Location: WinSock.h ln 458 #define AF_UNKNOWN1 20 /*Somebodys using this! */

Re: Ship building bug - ships stuck on '0' cycles left.

Postby Silligoose » Sat Feb 07, 2015 5:57 am

The relog wiped all the ships in the queue (at least they are no longer there) and nothing is in the factory.
Silligoose
 
Posts: 79
Joined: Wed Jan 29, 2014 7:18 am

Re: Ship building bug - ships stuck on '0' cycles left.

Postby Silligoose » Sat Feb 07, 2015 7:20 am

Spoke with Sypeheria in-game after relog. Tested building 1 ship at a time.

On the third ship, the ship got stuck on 0 cycles during building (slot 1).

Manually moved components from factory to warehouse, which had no effect. Queued up a second ship (slot 2), while the first one was still stuck.

The ship in slot 1, which was previously stuck, finished, while the new ship in slot 2 became stuck at 0 cycles. After giving it some time, I queued up 9 additional ships in slot 1, slot 3 - 10. 9 Ships finished building, including the ship in slot 2 which was stuck. The ship in slot 10 (aka the last ship queued again), became stuck at 0 cycles.

There was an abundance of funds, resources, CP, warehouse space available. That's all the testing I'd done regarding this bug.
Silligoose
 
Posts: 79
Joined: Wed Jan 29, 2014 7:18 am

Next

Return to Game Bug Reports

Who is online

Users browsing this forum: No registered users and 7 guests

cron